Auto door lock weak on passenger side
Results 1 to 8 of 8

Thread: Auto door lock weak on passenger side

  1. #1
    Spyderchat Enthusiast dasfreak's Avatar
    Join Date
    Feb 2011
    Posts
    42

    Default Auto door lock weak on passenger side

    Hi! Got a weird thing happening when the doors automatically lock when starting the car. The driver’s side locks completely, but the passenger on only goes about half way. if I manually lock them, both work every time. I can even lock the it completely from where it stopped half way manually so I don’t understand why it doesn’t automatically work correctly when starting the car. There are no issues automatically unlocking, just locking when starting and only with the passenger side. Thanx in advance for your time and support.
    DASFREAK

  2. Remove Advertisements
    SpyderChat.com
    Advertisements
     

  3. #2
    Spyderchat Enthusiast neomr2's Avatar
    Join Date
    Sep 2017
    Location
    NE Ohio
    Posts
    635

    Default

    Pull the inner door panel off, cycle the remote lock between lock/unlock, and look for any possible linkage binding which can be cleaned/lubed.

    Also check the motor connections for loose or dirty contacts.

    If all of those check good, the motor may be failing.
    2001 MRS with Mono Craft GT-300 Body

  4. #3
    Spyderchat Enthusiast dasfreak's Avatar
    Join Date
    Feb 2011
    Posts
    42

    Default

    Dang. I should have been more clear. When I say manually lock I mean pushing the powered lock button on the dash. It works 100% of the time using that. Its only when they lock when starting the car, the passenger side only goes half way, even at that point I can hit the lock button and it will go the rest of the way. I will open it and take a look though. Thanx for your suggestion.
    DASFREAK

  5. Remove Advertisements
    SpyderChat.com
    Advertisements
     

  6. #4
    Spyderchat Enthusiast dev's Avatar
    Join Date
    Dec 2004
    Location
    Silver Spring MD
    Posts
    22,657

    Default

    Quote Originally Posted by dasfreak View Post
    Dang. I should have been more clear. When I say manually lock I mean pushing the powered lock button on the dash. It works 100% of the time using that. Its only when they lock when starting the car, the passenger side only goes half way, even at that point I can hit the lock button and it will go the rest of the way. I will open it and take a look though. Thanx for your suggestion.
    In addition to neomr2 advice I would also clean any electrical contacts. Deoxit spray would work great in this application.


    KeyTechniques
    You can find our web page by typing "Keytechniques" on top of your browser and clicking the first result.
    Keyhole covers / Bumper plugs / MR-S key-chains / Door sills / Bushing kits and so much more.

  7. #5
    Spyderchat Enthusiast neomr2's Avatar
    Join Date
    Sep 2017
    Location
    NE Ohio
    Posts
    635

    Default

    Quote Originally Posted by dasfreak View Post
    Dang. I should have been more clear. When I say manually lock I mean pushing the powered lock button on the dash. It works 100% of the time using that. Its only when they lock when starting the car, the passenger side only goes half way, even at that point I can hit the lock button and it will go the rest of the way. I will open it and take a look though. Thanx for your suggestion.
    PM me your email address and I will send you the power door lock schematics when I get home from work.

    With the additional information, it sounds like you may have a bad connection or dirty/loose contacts that are dropping some voltage when starting, which is when the battery is at its lowest voltage and when the motor is weakest.
    2001 MRS with Mono Craft GT-300 Body

  8. #6
    Spyderchat Enthusiast
    Join Date
    Dec 2016
    Location
    Ithaca NY
    Posts
    1,233

    Default

    Quote Originally Posted by dasfreak View Post
    ...When I say manually lock I mean pushing the powered lock button on the dash. It works 100% of the time using that. Its only when they lock when starting the car, the passenger side only goes half way....
    It is still probably mechanical friction or binding. When the ECU locks the door, it provides a timed pulse, and this may not be quite long enough to overcome the friction in the mechanism. When you operate the switch with your finger, you make contact as long as you keep the button, and the locking becomes a self-fulfilling prophecy.

  9. #7
    Spyderchat Enthusiast seantc's Avatar
    Join Date
    Sep 2011
    Location
    Simi Valley Socal
    Posts
    549

    Default

    Mine stop working when its super hot outside. Like 100+ and in the sun all day. Never understood that one.

  10. #8
    Spyderchat Enthusiast neomr2's Avatar
    Join Date
    Sep 2017
    Location
    NE Ohio
    Posts
    635

    Default

    Quote Originally Posted by seantc View Post
    Mine stop working when its super hot outside. Like 100+ and in the sun all day. Never understood that one.
    You may have a shorted winding or two in the motor or the permeability of the magnetic core is temperature sensitive so that could be an issue - both reduce the magnetic field.

    Or the switch contacts may be an issue due to thermal expansion of the switch mechanism.

    Just some of the many electrical possibilities...

    2001 MRS with Mono Craft GT-300 Body

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •