MR2 SpyderChat banner

1 - 20 of 43 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Previously posted to FB but would like some help wherever I can get it.

I can’t get into lift properly. I rev up to lift and the car jerks violently but doesn’t redline when Lift kicks in. It will rev up to 8200 but very roughly. My Bolts are new, oil screen is new, new fuel injectors, spark plugs, ign coils. I have a secondhand lift solenoid which worked on a old motor and installed that at the oil control cover. I’ve done a reading on my fuel trims and they seem to be OK at warm idle

When I drive, the car seems to blow off pressure when I let off gas (audible). After driving, I found an oil leak at the oil control valve housing that dripped on my transmission so I’ve ordered a gasket.

Any other recommendations?
 

·
Registered
Joined
·
175 Posts
It sounds like you have some sort of aftermarket engine management going on.. possibly a turbo? How do you know the high cam profile isn't engaging? If it's the stock ECU there is an RPM limit at the changeover when the oil pressure switch doesn't see pressure to prevent any strange damage from the lower cam profile. The low cam profile system really isn't designed dynamically for that kind of speed.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
It sounds like you have some sort of aftermarket engine management going on.. possibly a turbo? How do you know the high cam profile isn't engaging? If it's the stock ECU there is an RPM limit at the changeover when the oil pressure switch doesn't see pressure to prevent any strange damage from the lower cam profile. The low cam profile system really isn't designed dynamically for that kind of speed.
No. It's stock N/A 2zz using JDM 2zz ECU. The blowoff i'm hearing comes when i let off the gas and i'm thinking it's a loss of oil pressure somewhere in the system.
 

·
Registered
Joined
·
1,033 Posts
If it can rev up to 8000 on the stock ECU then lift is engaging. What exhaust do you have? Are you getting any fault codes?
 

·
Registered
Joined
·
266 Posts
if you think that the problem is oil pressure, put a gauge on it and see whats going on. I know that they last thing to get oil is the lift system so it could be. Where do you live BTW?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
if you think that the problem is oil pressure, put a gauge on it and see whats going on. I know that they last thing to get oil is the lift system so it could be. Where do you live BTW?
I don't have a gauge and would need some resources for that sort of thing. I'm located in the Bay Area in California
 

·
Registered
Joined
·
186 Posts
Why JDM ecu? JDM engine with JDM sensors also? I am not familiar with JDM vs USDM 2zz differences, but if you're missing a sensor for the ecu it will get pissed.

I know from USDM 2zz ecu each solenoid has its own pressure switch. The VVL switch is NC (grounded) until activated.

At what rpm does it start jerking? Does it run smooth below 6k rpm?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
Why JDM ecu? JDM engine with JDM sensors also? I am not familiar with JDM vs USDM 2zz differences, but if you're missing a sensor for the ecu it will get pissed.

I know from USDM 2zz ecu each solenoid has its own pressure switch. The VVL switch is NC (grounded) until activated.

At what rpm does it start jerking? Does it run smooth below 6k rpm?
I've used the JDM ECU for over a year with no issues and borrowed a friend's USDM Matrix ECU with same issue. ECU can be ruled out.

It does run smooth under 6k RPM with no issues at all. It will jerk right lift engagement near 6,2k rpm
 

·
Registered
Joined
·
105 Posts
Is it getting up to the right temperature? Lift will not engage below a certain temperature.
 

·
Registered
Joined
·
1,033 Posts
I’d see if you can have someone rev it while you stick your head in the engine compartment and try to nail down where the hissing noise is coming from. Check the PCV system for any blockages or issues. As well as the intake and exhaust systems. If that doesn’t pinpoint your issue, I would do a leak down test.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #16
I’d see if you can have someone rev it while you stick your head in the engine compartment and try to nail down where the hissing noise is coming from. Check the PCV system for any blockages or issues. As well as the intake and exhaust systems. If that doesn’t pinpoint your issue, I would do a leak down test.
Issue does not happen while in neutral. Only happens while under load
 

·
Registered
Joined
·
1,033 Posts
Also confirm the lift solenoid is working properly by attaching a spare connector (or clip a couple wires to the pins but this is hard) and giving it 12V from the battery when the engine is idling. It should activate the big cam and stall the engine.
 

·
Registered
Joined
·
1,816 Posts
... The blowoff i'm hearing comes when i let off the gas and i'm thinking it's a loss of oil pressure somewhere in the system.
I don't think that oil is involved. An oil blowoff results in a big cloud of blue smoke and an unholy clattering ending with a dead engine. You are thinking in metaphors here. Maybe a more detailed description on what you are experiencing would help.
 
1 - 20 of 43 Posts
Top