MR2 SpyderChat banner
1 - 4 of 4 Posts

·
Registered
Joined
·
977 Posts
Discussion Starter · #1 ·
Hi guys, just finished up my swap with my crate motor and it runs.great.
I do however have a few issues that in sure you guys can assists.

I used my orig 5 speed box. Changed out clutch and pressureplate to exedy oem spec combo. The motor had anew flywheel which appeared to have a rough protective finish on it.
I bolted the clutch on and torqued it to spec.

1. I'm getting slight shudder on pedal just at the bite point. Is this fine as the parts are new and need to break in?
2. Didn't use loctite or any agent on the clutch bolts as the original clutch didn't have. Is this going to be a problem?
3. Used brand new oem copper gasket on exhaust at the head. Is it fine without sealer?
4. The balljoint on the ppe header between the header downpipe seems to leak no matter how much I tighten it. MWR says.no need for gasket with this type of joint, but am I suppost to add anything.else to make it seal?
5. Getting P 0171 system too lean error which I think may be linked to the exhaust as gas is escaping before the O2 sensor.
Or theres a leak on the intake. My long term fuel trim is sitting at +38. I'm sure I can hear pinking on take off.

I'm most concerned about the shudder on the clutch cos it will be a huge job to fix it.

Thanks for the assistance guys.
 

·
Registered
Joined
·
353 Posts
Im surprised no one answered any of ur questions :lol:

Congrats on getting the 2zz in (finally ^_^) now we have 3 2zz's in SA. Im waiting for a ride once u done running the 2zz in :icon_thumright:
 

·
Registered
Joined
·
553 Posts
1. I'm getting slight shudder on pedal just at the bite point. Is this fine as the parts are new and need to break in?

This is normal if you have a lightened fly wheel. Needs a little more rev for each shift. You will get use to it. It took me an hour to adapt.


2. Didn't use loctite or any agent on the clutch bolts as the original clutch didn't have. Is this going to be a problem?

Dunno. Never worked on a clutch/tranny before. But if torqued down to spec then I figure it should be ok.


3. Used brand new oem copper gasket on exhaust at the head. Is it fine without sealer?

Check for leaks. I always use a sealer.


4. The balljoint on the ppe header between the header downpipe seems to leak no matter how much I tighten it. MWR says.no need for gasket with this type of joint, but am I suppost to add anything.else to make it seal?

No doughnuts used??? Even on stock joints like that there is a doughnut used. I think even the knockoff OBX included one. Metal to metal will leak.


5. Getting P 0171 system too lean error which I think may be linked to the exhaust as gas is escaping before the O2 sensor.
Or theres a leak on the intake. My long term fuel trim is sitting at +38. I'm sure I can hear pinking on take off.

Exhaust leak. I had the same issue.
 

·
Registered
Joined
·
9,956 Posts
No sealer needed on header other than the metal gasket.

PPE balljoint needs no gasket, slight leak is expected since its metal on metal. Mine leaked but nothing to cause problems or even care about.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top