MR2 SpyderChat banner

1 - 10 of 10 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter #1
Just put these coilovers on a few days ago, were fine for a few days, washed car (and under frunk)and it rained ALOT and I noticed when I turn the steering wheel quickly the top hats squeak. Not too loud, but annoying. I was thinking maybe water got in there, causing bushing to squeak, they may need to break in a bit, or should I lube it?
 

·
Registered
Joined
·
131 Posts
Discussion Starter #3
Thanks, will try that after work!
 

·
Registered
Joined
·
1,473 Posts
Just put these coilovers on a few days ago, were fine for a few days, washed car (and under frunk)and it rained ALOT and I noticed when I turn the steering wheel quickly the top hats squeak. Not too loud, but annoying. I was thinking maybe water got in there, causing bushing to squeak, they may need to break in a bit, or should I lube it?
when i bought my megan coilovers. i was told to put some lithium grease onto the pillow ball mount to make it not squeak over time and also just to keep it lubricated so it wont rust?
 

·
Registered
Joined
·
131 Posts
Discussion Starter #5
Ok, I tried lubricating everything, nothing will stop the squeaking. It's def coming from the top hat, even removed sway bar endlinks to see if it was them squeaking, it's not. I tried everything, and BC won't answer the phone. Just sent them a email. Anyone else have this problem? Will it go away? Only put 200 miles on the coilovers so far. Car handles great, top hats just squeak LAMF when driving slow while turning the steering wheel. LOUD:mad:
 

·
Registered
Joined
·
131 Posts
Discussion Starter #7
No binding, everything is clear, took fronts off today and took them apart, put white lithium grease on the top hat, (the bearing in the top hat), so far so good... no squeak, but I don't want to curse myself! Haha! Isn't much else that could be squeaking. BC actually emailed me back, said to make sure 17mm nut was tight on top, which it was.
 

·
Registered
Joined
·
1,473 Posts
No binding, everything is clear, took fronts off today and took them apart, put white lithium grease on the top hat, (the bearing in the top hat), so far so good... no squeak, but I don't want to curse myself! Haha! Isn't much else that could be squeaking. BC actually emailed me back, said to make sure 17mm nut was tight on top, which it was.
yup. i think thats where i greased up mine too before i put them in. the megan dealer told me the same thing (top had nut has to be tight).
 

·
Registered
Joined
·
8,433 Posts
It's usually not the pillow ball mount that squeaks. It's spring perch where the spring sits against the mount. When you turn the wheels the spring turns and makes noise.

Does BC use any kind of rubber or teflon spacers between the spring and the mounts?
 

·
Registered
Joined
·
131 Posts
Discussion Starter #10
Yes, a soft plastic spacer.
 
1 - 10 of 10 Posts
Top