MR2 SpyderChat banner

1 - 20 of 87 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
Hey guys, as the title says my car is bogging down at 4,000 RPMs and up in every gear. The only codes I’m getting are two faulty o2 sensors that are getting replaced tomorrow. Can this be the reason? I have a limited knowledge of cars but I know the o2 sensors are what’s supposed to make sure the right amount of gas and air gets mixed to combust right?

Other than that my only other idea would be a bad fuel pump. What do you guys think? Thanks.
 

·
Registered
Joined
·
5,758 Posts
I smell Main Cat Failure..

Year and millage on the car..

And oil consumption?..

Cap
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
I smell Main Cat Failure..

Year and millage on the car..

And oil consumption?..

Cap
Oil Consumption is pretty high. I’m having to top it off atleast once a week. It’s a 2000 and it just broke 100k a day ago
 

·
Registered
Joined
·
5,758 Posts
What are your Maintenance abilities?.. This will determine the next steps..

Cap
 

·
Registered
Joined
·
52 Posts
Discussion Starter #5
What are your Maintenance abilities?.. This will determine the next steps..

Cap
So, I replaced the bad o2 sensors but it didn’t seem to fix a thing. i also had some new codes pop up on the diagnostics tool.
P0174
P0171
P1315
So to recap, it still takes forever to turn over, I can’t get over 4,000 RPMs and also even under 4,000 RPMs if I push the gas too hard it bogs out, in every gear. It’s like it physically can’t get passed 4,000.
I’m not very mechanically inclined but my dad is and he helps me with everything. What should we look at next?
 

·
Registered
Joined
·
5,758 Posts
IF the Main Cat is Constipated, it will not let the car breath..

If you pull the O2's out.. Disconectt them from the Wires.. and leave the O2 Holes Open.. Start and drive the Car.. It will be VERY loud!.. Just see if you can get the car to move, and does it run better?

IF so you have a Plugged cat system.. it will run better..

Then the question is what do you do next.. you need an engine and a Cat System..

But it could be as simple as a Plugged air filter.. Have you checked?

Cap
 

·
Registered
Joined
·
52 Posts
Discussion Starter #7
IF the Main Cat is Constipated, it will not let the car breath..

If you pull the O2's out.. Disconectt them from the Wires.. and leave the O2 Holes Open.. Start and drive the Car.. It will be VERY loud!.. Just see if you can get the car to move, and does it run better?

IF so you have a Plugged cat system.. it will run better..

Then the question is what do you do next.. you need an engine and a Cat System..

But it could be as simple as a Plugged air filter.. Have you checked?

Cap
The K&N air filter I have on it is actually rather dirty but it doesn’t look dirty enough to make the car bog down that bad. I actually already ordered the cleaning kit and I’m waiting on it.
 

·
Registered
Joined
·
5,758 Posts
If you take out the Air Filter.. Give it a run, and if the car runs better, it's the air filter..

Cap
 

·
Registered
Joined
·
32 Posts
Hey guys, as the title says my car is bogging down at 4,000 RPMs and up in every gear. The only codes I’m getting are two faulty o2 sensors that are getting replaced tomorrow. Can this be the reason? I have a limited knowledge of cars but I know the o2 sensors are what’s supposed to make sure the right amount of gas and air gets mixed to combust right?

Other than that my only other idea would be a bad fuel pump. What do you guys think? Thanks.
Could be the MAF sensor is dirty. Clean it and reset ECU. If you search Google there is a tutorial on Midshiprunabout website.
Was a Toyota mechanic 98-07 and when the mk3 came out often customers would bring car for service and report flat spots and the like.

If you have a K&N it can splatter oil on the MAF too.
 

·
Registered
Joined
·
32 Posts
If you replaced everything aforementioned including the MAF, probably more likely the Cat is full of oil as mentioned.

Troubleshooting at this stage starts to get labour intensive and expensive.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #11
If you replaced everything aforementioned including the MAF, probably more likely the Cat is full of oil as mentioned.

Troubleshooting at this stage starts to get labour intensive and expensive.
Alright where should I start first?
 

·
Registered
Joined
·
32 Posts
Have you inspected the plugs (they will look bad if it's using so much oil probably) and tested the coil packs on each plug ?

P1315 !

Swap the coil packs around and see if the fault moves from cylinder 4.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #18
So new codes are
P0174
P0171
P1315

And the original codes were P0135 and P0155 ?
I went out and ran the diagnostics tool and as of currently the codes I’m getting are P0300
P0303
P0171
P0174
P0100
P0110
P0135
P0155
 

·
Registered
Joined
·
52 Posts
Discussion Starter #19
Have you inspected the plugs (they will look bad if it's using so much oil probably) and tested the coil packs on each plug ?

P1315 !
For some reason I’m not getting P1315 anymore. I also did move coils around the other day to see if it’d follow. My codes were erased yesterday and I’ve drove the car around a bit since then.
 
1 - 20 of 87 Posts
Top