MR2 SpyderChat banner

1 - 6 of 6 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Random question. I had my spyder out last night and something kind of strange is happening. If I take it to redline, the check engine light will flash for a split second and turns off. Engine runs fine otherwise and no codes were stored. The car has never done this before.

Over the winter I did gut the precats (they were perfect, car burns no oil) and replaced the main cat. My car is a manual swapped SMT, so I’m running a celica ecu. I do have the correct single o2 sensor placement after the collector.

I’m thinking this is some kind of misfire, o2 sensor issue or vacuum leak, but not sure how to diagnose without a code being thrown. Anyone else have this issue? I don’t want to just start throwing parts at this.

Thanks!
 

·
Registered
2003 Spyder
Joined
·
6 Posts
You'll have to wait for it to throw a code, any other approach without knowing the problem is not productive.
 

·
Registered
Joined
·
5,886 Posts
Generally a Flashing Cell is a detected Missfire.. I don't know why it's not storing..

Cap
 

·
Registered
Joined
·
24 Posts
if it's at the very top of the rpm range, one thing to check would be the bolts that hold the ignition coils in. Happened to me on track, and all I could find was that one coil bolt was loose.
Tightened it and it didn't do it anymore ¯\(ツ)
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6
Are you revving it up to the fuel cut?
I’m not sure if I hit the fuel cut or not. I try to not to redline often, but I do have some fun on the occasional on ramp and I haven’t noticed this happening before.

Does hitting the fuel cut trigger a light?
 
1 - 6 of 6 Posts
Top