MR2 SpyderChat banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just happening...car is suddenly nosing out when I accelerate from a stop or a slow to turn, etc. No check engine lights. Any ideas? Takes a bit but does engage then performs fine and no problems at higher speeds. This is not happening all the time, seems very random.
 

·
Registered
Joined
·
708 Posts
I dont completely understand your description but you are saying that the car loss power when accelerating from stop then at higher rpm it seems to be normal? Is your car smt or manual transmission? any modifications? how many millage it have? Does the car makes some noise when it loss power?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
On average about 20% of the time leaving a stop it has this problem. It has the smt trans, it feels as if your trying to start off in the wrong gear, but the engine sounds normal, and does not bog down. Almost as if it had a govenor on it to keep it from accelorating. The car is all stock as far as we know with about 126k miles.
 

·
Registered
Joined
·
2,531 Posts
I'm not promising it will fix anything but at 126k miles, you might as well go ahead and clean your MAF.

I've had a similar problem before caused by incorrectly sized intake piping, but since you are all stock, I'm not much help. Does it do this after the car is warmed up? Is it worse when you first get in the car for the day?
 

·
Registered
Joined
·
5,621 Posts
Go to the SMT Forum.. Search for the 'No Throttle Gremenlin'.. or some such spelling..

You have a Bad APS.. ( NOT the TPS that Toyota will try and Sell You )

Cap
 

·
Registered
Joined
·
1,016 Posts
Cap, just want to say here: I feel much better about owning a 10 year old car (Although that is young for a toyo, I know) knowing you are an active member of this forum.... thanks.
 
1 - 8 of 8 Posts
Top