MR2 SpyderChat banner
1 - 20 of 26 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Good evening from greece.

I have a problem with my o2 sensor since the pre-cat removal.

Well the full story is like this.

1)i removed the precat as i saw in a thread in this forum.
2)after about 500 klm i got the error.
3)went to the dealer who told me that was error from both sensors. Bank 1,Bank 2
4)Did reset them and after 2-3 klm got the error again.
5)cause of money i left it about 4-5 months with the check engine error on without taking any action.
6) before 3 days i bought a che style header,istalled it and reset the error code that was the same.both sensors.
7)after about 50 klm again i got the error...

Pls tell me what shall i do or change?

We dont have mechanics that are specialized in this car here,so i have heard many different opinions.

Sorry for my bad english,but i love all the community here and i have read almost all the threads!!
Thank you
 

·
Registered
Joined
·
132 Posts
If its the O2 sensors did you try buying new ones and seeing if that fixes the issue?
 

·
Registered
Joined
·
3,643 Posts
The O2 sensors or wires can get damaged during the removal and re-install.I would replace them.Disconnect the battery for a few minutes to reset the ECU.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #4 ·
Disconeccting the battery turns off the error?

I will buy new,but i dont know if this is the real problem or the ecu is damaged bcs i left if so much time with the error active.
 

·
Registered
Joined
·
303 Posts
Replacing them should fix your problem. You have to be very careful when removing them, that has to be when the damage happened. Let us know if you replace them, reset the computer (taking the battery cables off will reset it) and you still have the problem. When changing over to a header I got lucky and only had to replace one.
 

·
Registered
Joined
·
5,904 Posts
ecu is damaged bcs i left if so much time with the error active.
About the Only way to Hurt the ECU, is to hit it with Lightning.. I'm not kidding, they are Robust!..

As was said before, it's likely the O2 Sensor..

No you did not hurt anything..

Cap
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #8 ·
I dont have the codes now.
I remember that was bank 1 sensor 1 and bank 2 sensor 1.

So i had to replace both as i see..

I have read many threads before posting this and i ve seen lots of opinions like ''the ecu maybe is dmged from reading error so much time'' , ''the heater circuit'' , ''reading 1 error,but the true error might be in the cat sensor".
If i get the codes and post em tommorow,will we have a clear conclusion?
 

·
Registered
Joined
·
5,904 Posts
Yes..
The Code Numbers will tell if the ECU is Complaining about the O2 Sensor, or the Heater INSIDE the O2 Sensor..

And it will also tell if it's the Left Side Sensor, Right Side Sensor, or the 'Last Sensor' ( After Cat )..

Cap
 

·
Registered
Joined
·
1,986 Posts
You can get a cheap code reader of of Ebay for less than € 30.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
P0141 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)

So i guess i change the passenger sensor and the problem will be fixed?
 

·
Registered
Joined
·
5,904 Posts
NOPE!

That is the After Cat Sensor.. the one that is plugged in behind the Left Rear Tail Light..

It has nothing to do with Performance.. you can keep running it like that..

Cap
 

·
Registered
Joined
·
745 Posts
It job is to analyzed you "cat", it won't make your engine used more gas. Replace it and report back in ~50 miles.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #16 ·
NOPE!

That is the After Cat Sensor.. the one that is plugged in behind the Left Rear Tail Light..

It has nothing to do with Performance.. you can keep running it like that..

Cap
What do you mean??
There are 2 sensor on the header.. one left and one right.
And a third sensor at the middle cat,before the exchaust.

You mean the third one?

And how is it possible after changing the header and reseting the 2 errors of the header's sensor,to get error on the third one??
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #17 ·
Do i answer to my question with this old answer to a thread i found??

<div class='quotetop'>QUOTE (hyojiggy @ May 19 2009, 02:50 PM) <{POST_SNAPBACK}></div>
wait a minute...

is this because of my gutted pre-cat? will the P0141 keep shooting out even if i get a new o2 sensor?[/b]

No, it's a fairly common issue for the Spyder. The code indicates a bad heater sensor circuit on the 02 sensor itself. The code has nothing to do with anything it may or may not be sensing about your cat performance. After replacing the sensor it should be just fine. If it were a p0420 or something related to what your sensor is reading, then you might have to start worrying about mods you've done.

I would say though (this is just a theory) that the 02 sensors don't really like aftermarket or modified exhaust components. Issues with them seem to arise for people who have done so, in my observation on this board.
 

·
Registered
Joined
·
5,904 Posts
IF the ONLY code you have is a P0141, then the ONLY thing the ECU is complaining about is the Heater Curcuit Malfunction on the Last O2 Sensor.. the After Cat Sensor..

The ONLY way to fix that is the Replace that O2 Sensor.. Unless you want to ignore it.. either way the Car will run the Same.. and NO Damage is being done..

Cap
 

·
Registered
Joined
·
5,904 Posts
The 141 is LIKELY caused by the Banging of the Wrenches.. has NOTHING to do with Mods on the Car, it has EVERYTHING to do with working on the car and bumping and banging things..

My 141 poped up at about 120 K Miles, and I replaced my O2 Sensor.. the Other two are Still Going at 227K Miles..

Cap
 

·
Registered
Joined
·
7,703 Posts
If this helps, I still have the pre-cats and have had to replace both sensors, at different times. Easy to do with the right tools. Once replaced, disconnect the batter for 5 minutes or so, reconnect battery and it should clear the codes and all should be fine.

I worked as described for me without a problem
 
1 - 20 of 26 Posts
Top