MR2 SpyderChat banner

1 - 13 of 13 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter #1 (Edited)
Odd occurrence.

I thought my reverse tail lights were out. Popped it into reverse had the lady look at the lights not on. This was with headlights off.

Today a Z06 pulled up and notified me that my reverse lights were on. Weird went to check sure enough they are constantly on. Wiring fix? Where to start on this one?
 

·
Registered
Joined
·
229 Posts
Discussion Starter #4
Couple things to add

My drivers side rear signal light was out. I had checked the reverse lights before replacing the bulb. At that time the reverse lights did not come on at all.

Replaced the bulb and signal works.

Now reverse lights are on ALL the time as in start the car by are on like daytime running lights. When headlights are turned on, the reverse lights are on.

Prior to the bulb change I ran a PO136 if I remember correctly Bank 1 Sensor 2. So I replaced that which is in the general vicinity. Now I am running a PO141 Bank 1 Sensor 2 heater circuit.
 

·
Registered
Joined
·
229 Posts
Discussion Starter #6
The backup lights are controlled by a switch mounted on the transmission.
It sounds like this switch has malfunctioned.
It could also be that the wires going to the switch are touching, but that's very unlikely.
Do you happen to have a picture handy? Ill have to tackle this in the morning.
 

·
Registered
Joined
·
3,812 Posts
Reverse switch for lights is smack dab in the middle right on top of the tranny. You can see the blue wire lead going to it and it would be right underneath the shifter cables if you look at an installed transmission. There are two types of reverse switches on the six speed, the one you see in the picture, and the other type which has the wires coming out of the top of the switch instead of the side like the picture. You need to use the 5 speed switch from the spyder with the side exit wires, the top mounted wires will get hit by the shifter bits as they move around. To check the switch just disconnect the wires at he tranny harness and check for no continuity when in 1-6/ neutral and continuity when in reverse. It is just an on/off switch and if it is bad just unscrew it out the top and put in another.

 

·
Registered
Joined
·
98 Posts
Rob: I am not an expert but I suggest checking out the wiring first. Check the ECU behind the driver seat storage area and see how the wiring is.

0141 is your oxygen sensors after the cat. You need to get it replaced.

Anyways Good Luck! :)
 

·
Registered
Joined
·
229 Posts
Discussion Starter #12
Rob: I am not an expert but I suggest checking out the wiring first. Check the ECU behind the driver seat storage area and see how the wiring is.

0141 is your oxygen sensors after the cat. You need to get it replaced.

Anyways Good Luck! :)
I replaced it already was running po136.

141 is heater circuit

I wasn't able to check the actual switch as previously posted. I couldn't reach it well so just left it for the moment. Doesn't affect anything really for the moment. I'll take a look behind there. Going to have to remove some of that stuff anyway when I put in the hard dog.
 
1 - 13 of 13 Posts
Top