MR2 SpyderChat banner

1 - 20 of 36 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
2000 Toyota mr2. 70000
Car starts rough, until excelleration. During the rough it kicks flashing check engine.
Random misfire and cylinders 3 &4 are the code
replaced iacv....nock off...injectors oem checked for vaccum issue not finding any. Ordered 2 coils oem. Ran live data to rule out fuel issue since i replaced pump 6 months ago. Not sure how to read so ive included to see if the helps. Runs very close to normal until come to a stop and misfire becomes more apparent.
by the way i beat rod knock replaced all 4 bearings thanks cap and others for details went easily and 100% after. Now im stuck at issue before spun bearing.
any help will be appreciated
david
 

Attachments

·
Registered
Joined
·
4,404 Posts
What OBD2 scantool app and OBD2 adapter are you using? The numbers it reports for LTFT are out of range and unrealistic. -98% LTFT is not a running condition that is possible to occur. The consistently 0% STFT would occur only in open loop which I don't think is what you are reporting. Probably there is an error in the programming of the app. Try use a different app or different OBD2 adapter. The STFT and LTFT are sent to the app as a hexadecimal number that the app then decodes using its internal logic and produces the display and the log. If the internal logic is incorrect or if the hexadecimal number is corrupted somehow by the OBD2 adapter you will get garbage like what you have posted.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Thanks for the info just purchased this reader..ill find another ....any recommendation
 

·
Registered
Joined
·
8,846 Posts
Fuel trims are the most important thing you can look at. While you wait for new coils to arrive, you can move them to see if the misfire follows it.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
Also updates software on obd2 bluedriver....img 47 is idle........img 603 is driving
 

Attachments

·
Registered
Joined
·
26 Posts
Discussion Starter #11
Also from cold one block away i came to a stop and the check engine blinked until up to speed
 

·
Registered
Joined
·
8,846 Posts
I’Ve posted fuel trims
That's difficult to look over... give me a rough idea of what's going on. STFT and LTFT B1 and B2 what are the ranges you see at idle? what are they like at 1500rpm?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #16
That's difficult to look over... give me a rough idea of what's going on. STFT and LTFT B1 and B2 what are the ranges you see at idle? what are they like at 1500rpm?
Off and on long startups....meaning sometimes starts easy...other times requires fuel...once started runs tough until in gear seems to quit....if fuel is given no check engine....other wise kicks right away....times when not on will come on next time come to stop / idle.....when it comes on it blinks....on the road no issue apparent...however once it comes to idle it does misfire...no loss of power but eating fuel like crazy...ive replaced injectors oem green,,,,replaced nock off iacv....fuel pump upgraded....ordered two oem coils
 

·
Registered
Joined
·
5,283 Posts
I have had a bad IAC valve that caused a very rough idle when cold started. It caused misfire codes. At operating temp it ran fine. A dirty injector can cause out of range fuel trims. I run a bottle of Chevron Techron once in awhile. It has cleaned up the injectors, giving better trim values and stopped misfire codes. Moving #4 injector to a different bank to see if the code follows can give a clue about the misfire. What injectors did you purchase, brand new from Denso?
 

·
Registered
Joined
·
8,846 Posts
Off and on long startups....meaning sometimes starts easy...other times requires fuel...once started runs tough until in gear seems to quit....if fuel is given no check engine....other wise kicks right away....times when not on will come on next time come to stop / idle.....when it comes on it blinks....on the road no issue apparent...however once it comes to idle it does misfire...no loss of power but eating fuel like crazy...ive replaced injectors oem green,,,,replaced nock off iacv....fuel pump upgraded....ordered two oem coils
sounds like a shotgun repair.

You're going through fuel like crazy? Then it's running rich. need fuel trims and I can tell you more. What average range are you seeing, or what high and low are you seeing from b1s1 and b2s1 long and short? It sounds more like there isn't enough air at idle. The throttle pedal is an air control valve, not a gas pedal. it gives no extra gas.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #19
I have had a bad IAC valve that caused a very rough idle when cold started. It caused misfire codes. At operating temp it ran fine. A dirty injector can cause out of range fuel trims. I run a bottle of Chevron Techron once in awhile. It has cleaned up the injectors, giving better trim values and stopped misfire codes. Moving #4 injector to a different bank to see if the code follows can give a clue about the misfire. What injectors did you purchase, brand new from Denso?
Yes denso oem
 
1 - 20 of 36 Posts
Top