MR2 SpyderChat banner

1 - 7 of 7 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
Someone please tell me why, every time, my car f,s up it constantly, reads the tcu, is the problem and everyone wants to replace it, I have done this, and it is not the issue or maybe these things just suck. Does anyone have an scuba, for a 2002, smt, I think this is the problem because everything else has been replaced but the ecupse, pm me if you have an ecu.
 

·
Registered
Joined
·
5,833 Posts
Does anyone have an scuba, for a 2002, smt, I think this is the problem because everything else has been replaced but the ecupse, pm me if you have an ecu.
So are you looking for a TCU ( Trans Computer ) or an ECU ( Engine Computer )?..

Cap
 

·
Registered
Joined
·
1,029 Posts
I still seriously doubt it's an ecu problem. I'm leaning towards either a funky clutch stroke sensor or just a ripped up transmission (leaning harder towards the tranny). Have you changed the gear oil recently and were there metal pieces bigger than glitter in it?
 

·
Registered
Joined
·
142 Posts
Discussion Starter #5
response

My car has a new trans , gsa and clutch, over 10,000 in new parts over the last year, I bought an extended warranty and am trying to put it to use now and keep mine in mg pocket this year. First place I took the car too, diagnosed the tcu was defective, I let them know it had been replaced,and all the gsa system entirely, except ecu, would like to locate a ecu to eliminate the thought that it could be the culprit, because it is still original.
 

·
Registered
Joined
·
142 Posts
Discussion Starter #7
?

Warranty...I don't think so..... Car has a glitch somewhere in the software, me and with the great help of Cap, and others have been back and forth on the car, as well as several dealerships in my area, after all the new parts and work, the car still continues to, loose the gear with no acceleration in the second and forth gear and slip out on reverse and at a neutral position, not be able to pin point exactly what gear it is in. What I have done to compensate and drive the car is as follows, when backing up the car it must slighlty roll and then it will find first gear, so in reverse just before I come to a complete stop I shift to first. second I always accelerate up when in second and forth, if I am deaccelerating I make sure i skip those gears and do not spend any time there with my foot off the gas,when the car is parked with just the key on cold or hot, it will engage and disengage the either GSA, or the clutch pin, repeatedly. this sounds as a software malfuntion to me the brain is going haywire even when the car si not in motion.
 
1 - 7 of 7 Posts
Top