MR2 SpyderChat banner

1 - 20 of 20 Posts

·
Premium Member
Joined
·
1,823 Posts
Discussion Starter #1
i am now the proud owner of a '00 Spyder!!! i brought her home on Saturday and already have her sitting on jack stands ready to gut the precats tonight... just need to rent the O2 socket...

she needs a bit of work first.

the top is torn where it meets the rear window... but i may wait till after the summer since i plan to just drive her around topless :D...

need to source a few buttons and the tools for the spare were missing...

but then i'll plan to do a few appearance and chassis mods... im so excited!!! look forward to learning loads from the boards... i'd like to thank everyone for their help thus far...
 

·
Premium Member
Joined
·
1,823 Posts
Discussion Starter #3
I patched my ragtop with some super-rubber cement (upholstery grade stuff) and vinyl. It was getting tears by the back glass. So far the repair is holding fine.

What "buttons" do you need?
thanks maybe ill see if i can temp fix it with the cement before i drop the money for a new top...

i need the little button for the fresh air/recirc lever... the 'PULL' cap for the top latch... one of the latches for the Frunk cover... and the push pins that hold the plastic surround in the frunk...
 

·
Premium Member
Joined
·
1,823 Posts
Discussion Starter #8
Order them from a Toyota dealership.
You may find them cheaper on the internet, but the shipping charges will be than the savings.


"one of the latches for the Frunk cover"
If you mean the spare tire cubby lid, you're out of luck.
I believe the lid is sold as an assembly only.
Check the SpyderChat For Sale section for cars that are being parted out.


edit:
sh4branze found a source for the plastic clips/rivits http://spyderchat.com/forums/showthread.php?51447-Found-a-deal-on-button-rivits.&p=830333#post830333
thanks for the link...

here's another dumb question... the DOME light when switch to the middle should turn on/off with the door right? i get nothing... it does work on ON/OFF, but middle seems to also just be OFF...
 

·
Registered
Joined
·
1,115 Posts
the DOME light when switch to the middle should turn on/off with the door right? i get nothing... it does work on ON/OFF, but middle seems to also just be OFF...
Yes you are right.

Issue 1 - I find the bulb 's contact points are flaky. Check with a voltmeter if the voltage is there.
Issue 2 - Make sure the screws are all tight in the dome assembly, if they are loose then this also causes flaky behavior. The left screw acts as a chassis ground contact point.
 

·
Registered
Joined
·
3,594 Posts
Is this what you are looking for?



I just needed to replace mine. Stealership wanted $27 a piece for the latches and there were only a few left in the county. I posted a WTB post in the sales section letting community members know I was looking for replacement latches and bought a couple from another member. You might want to try that route. I had to bump my post to the top several times before someone who had some to sell took notice. Good luck with your search and welcome to permagrin land.
 

·
Premium Member
Joined
·
1,823 Posts
Discussion Starter #11
Yes you are right.

Issue 1 - I find the bulb 's contact points are flaky. Check with a voltmeter if the voltage is there.
Issue 2 - Make sure the screws are all tight in the dome assembly, if they are loose then this also causes flaky behavior. The left screw acts as a chassis ground contact point.
i'll break out the DMM this week and see if i can diagnose it... without that light i can't see $#@% when im trying to get into the car at night... i may wire in a few LED footwells too...

Is this what you are looking for?
yes that is exactly what i am looking for... i just need one... i'll take your advise and try the classifieds... thanks!!!
 

·
Registered
Joined
·
527 Posts
i'll break out the DMM this week and see if i can diagnose it... without that light i can't see $#@% when im trying to get into the car at night... i may wire in a few LED footwells too...



yes that is exactly what i am looking for... i just need one... i'll take your advise and try the classifieds... thanks!!!
I gutted my FRUNK. I still may have the parts (in good shape) out it the barn. If I do u can have them... Depending on your location, u will need to pay for shipping
 

·
Registered
Joined
·
103 Posts
i am now the proud owner of a '00 Spyder!!! i brought her home on Saturday and already have her sitting on jack stands ready to gut the precats tonight... just need to rent the O2 socket...
I just did my '02, and rented the O2 wrench on the end of a bar...didn't work. The socket should, but I found an open end wrench (think it was 22mm) took them off and put them back on fine, albeit not torqued, but all they do is hold themselves in....;) All I had to do was get the top shield off (a major pain in the butt; top two bolts rusted solid).

Is a great first project...if you get past that, the rest is downhill....;)

Congrats and enjoy!
 

·
Registered
Joined
·
4,128 Posts
thanks maybe ill see if i can temp fix it with the cement before i drop the money for a new top...

i need the little button for the fresh air/recirc lever... the 'PULL' cap for the top latch... one of the latches for the Frunk cover... and the push pins that hold the plastic surround in the frunk...

You should think about getting Devs Frunk cover if you plan on getting any of the tower bracing for the front he also has a nice piece for the pull tab.
 

·
Registered
Joined
·
544 Posts
I gutted my FRUNK. I still may have the parts (in good shape) out it the barn. If I do u can have them... Depending on your location, u will need to pay for shipping
I also just need one spare tire cover latch. So I'll take the other one and I'll gladly pay shipping!
 

·
Premium Member
Joined
·
1,823 Posts
Discussion Starter #16
I gutted my FRUNK. I still may have the parts (in good shape) out it the barn. If I do u can have them... Depending on your location, u will need to pay for shipping
I also just need one spare tire cover latch. So I'll take the other one and I'll gladly pay shipping!
t-town... that would be great... i'll glady pay for the shipping... i just need one so the other one can go to Russell...

I just did my '02, and rented the O2 wrench on the end of a bar...didn't work. The socket should, but I found an open end wrench (think it was 22mm) took them off and put them back on fine, albeit not torqued, but all they do is hold themselves in....;) All I had to do was get the top shield off (a major pain in the butt; top two bolts rusted solid).

Is a great first project...if you get past that, the rest is downhill....;)

Congrats and enjoy!
i'll get pics up soon... i just finished gutting the precats last night... i'm just waiting for the gaskets and replacement bolts from the stealership to arrive... should be tonight... alot of my bolts for the heat shield were rusted but i soaked them in PB overnight... that stuff is amazing... the 3 amigos were a piece of cake with an impact gun... the hardest bolt for me was the 14mm mount bolt... and when i took one of the header bolts off, it backed out the whole stud... so i got a new one coming too...

i want to paint the heat shields before putting everything back together... i got them cleaned up a bit and slightly scuffed... i just need to address some of the rust on the edges... maybe with some naval petroleum jelly tonight... first coat should be on tonight...

did anyone think about using a dremel to port match the oem header to the gasket? i have a huge gap in a few of the ports...

You should think about getting Devs Frunk cover if you plan on getting any of the tower bracing for the front he also has a nice piece for the pull tab.
yea i saw that... i'm waiting to see a black version of the PULL plate cause i'm not into all that bling of the SS... so if i get a front upper strut bar, i can't use the oem frunk cover? i'd like to keep the OEM look if possible...
 

·
Registered
Joined
·
489 Posts
Welcome and congratulations!
 

·
Registered
Joined
·
1,733 Posts
yea i saw that... i'm waiting to see a black version of the PULL plate cause i'm not into all that bling of the SS... so if i get a front upper strut bar, i can't use the oem frunk cover? i'd like to keep the OEM look if possible...
At the least, you'd need to cut two openings in the plastic cover surrounding the frunk bin to access the top of the strut towers. (I'll show you on mine one of these days.) Even then, access to the frunk bin is a limited, because the bar limits the angle you can open the frunk bin cover. Some people had cut down the frunk bin cover and used a piano hinge to resecure it to the frunk bin. I just pull the bin cover off carefully.. but the best solution is to remove the bin cover and replace it with Dev's frunk bin cover.

Rich
 

·
Premium Member
Joined
·
1,823 Posts
Discussion Starter #19
At the least, you'd need to cut two openings in the plastic cover surrounding the frunk bin to access the top of the strut towers. (I'll show you on mine one of these days.) Even then, access to the frunk bin is a limited, because the bar limits the angle you can open the frunk bin cover. Some people had cut down the frunk bin cover and used a piano hinge to resecure it to the frunk bin. I just pull the bin cover off carefully.. but the best solution is to remove the bin cover and replace it with Dev's frunk bin cover.

Rich
thanks Rich... we will catch up real soon... i'm gonna need some ideas... with all the cowl shake i get at high speeds i think a BP and FSTB is going to be on order...
 

·
Premium Member
Joined
·
1,823 Posts
Discussion Starter #20
Yes you are right.

Issue 1 - I find the bulb 's contact points are flaky. Check with a voltmeter if the voltage is there.
Issue 2 - Make sure the screws are all tight in the dome assembly, if they are loose then this also causes flaky behavior. The left screw acts as a chassis ground contact point.
ended up being a bad driver door switch... noticed that the DOOR indicator on the dash wasn't lighting up... the fuse was fine so i pulled both switches and checked for continuity... driver side was dead... looks like i'll be calling up the stealership... at least it wasn't anything insane...
 
1 - 20 of 20 Posts
Top