MR2 SpyderChat banner

1 - 4 of 4 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
...so this problem has been driving me nuts. My turn signals will randomly start doing the fast blinking thing that says 'Hey, one of your bulbs is burned out, dummy, go check it!' I check my bulb (rear right side, usually). Not burned out. Put it back in, and the problem goes away...but then occasionally shifts to the OTHER side rear turn signal bulb! Check that, also not burned out.

Is there some relay somewhere that might be faulty? I'm hoping that's the case. I don't think it'd necessarily be a frayed insulation on a wire issue, since it seems to hop sides on me. That's why I was thinking a bad relay. Maybe it's a relay that controls the pulses of electricity to each turn signal, and the relay can't get enough voltage through, so it thinks the bulb is burned out. It's only happening at the rear of the car. The front bulbs are blinking (quickly, when this happens, of course). They do light up. Thoughts, wiring diagrams or anything that might help? Thanks!
 

·
Registered
Joined
·
4,011 Posts
I'd start by hosing down both rear bulbs/sockets with this stuff. *Corrosion block*
It solved crappy-connection problems on my Jaguar many times. If the problem persists, maybe work your way forward and hose down any quick-disconnect connectors feeding the rear lights, and the flasher relay pins and socket. I routinely squirt some on every connector I pull apart.
 

·
Registered
Joined
·
5,832 Posts
+1 what Cyclehead said..

It wont be a Flaky relay.. If the Blinker is doing the Fast Flash, then one lite is not blinking.. so something is not making conection..

Cap
 

·
Registered
Joined
·
1,445 Posts
If the Blinker is doing the Fast Flash, then one lite is not blinking.. so something is not making conection..

Cap
I Agree. Most common thing would be no ground.


I had a problem a while back with a tail light that would come and go. Could find nothing wrong. Replaced both tail light bulbs, no more problems.
 
1 - 4 of 4 Posts
Top